VERITAS NetBackup™ 6.0 for Microsoft SharePoint Portal Server 2001

System Administrator’s Guide

for Windows

N152708
September 2005
Disclaimer

The information contained in this publication is subject to change without notice. VERITAS Software Corporation makes no warranty of any kind with regard to this manual, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. VERITAS Software Corporation shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this manual.

VERITAS Legal Notice

Copyright © 2003-2005 VERITAS Software Corporation. All rights reserved. VERITAS, the VERITAS Logo, and NetBackup are trademarks or registered trademarks of VERITAS Software Corporation or its affiliates in the U.S. and other countries. Other names may be trademarks of their respective owners.

Portions of this software are derived from the RSA Data Security, Inc. MD5 Message-Digest Algorithm. Copyright 1991-92, RSA Data Security, Inc. Created 1991. All rights reserved.

VERITAS Software Corporation
350 Ellis Street
Mountain View, CA 94043
USA
Phone 650-527-8000
Fax 650-527-2908
www.veritas.com

Third-Party Copyrights

For a list of third-party copyrights, see the NetBackup Release Notes appendix.
# Contents

**Preface** .......................................................... v  
Getting Help ............................................................ vi  
Finding NetBackup Documentation ................................. vi  
Accessing the VERITAS Technical Support Web Site .......... vi  
Contacting VERITAS Licensing ................................... viii  
Accessibility Features .............................................. viii  
Comment on the Documentation ................................... viii  

**Chapter 1. Introduction to NetBackup for SharePoint Portal Server** ............ 1  
Features ................................................................. 2  
Backup Operations ...................................................... 3  
SharePoint Portal Workspace Backup of the Documents Folder ........ 3  
Methods ................................................................. 3  
  Automatic Backups .................................................. 4  
  Manual Backups ..................................................... 4  
  User-Directed Backups ............................................. 4  
Contents of a SharePoint Server Backup ........................... 4  
Restore Operations ..................................................... 5  
Server-Directed Restore .............................................. 5  
Workspace Restore ..................................................... 5  
Redirecting a Restore to a Different Client ....................... 6  
Redirecting a Restore to a Different Path ......................... 6  
Limitations on Backups and Restores .............................. 6
Chapter 2. Installing the SharePoint Agent ............................................... 9
  System Requirements ........................................................................ 10
  Software Requirements ................................................................. 10
  Account Requirements .................................................................. 10
  Registering the License Key .......................................................... 11

Chapter 3. Configuration ................................................................. 13
  Configuring the NetBackup Client Service Log On Account .......... 14
  Configuring Backup Policies ......................................................... 15
  Adding a New Policy ...................................................................... 15
    Description of Attributes .......................................................... 16
  Adding New Schedules ............................................................... 17
  Types of Backups .......................................................................... 18
  Schedule Properties ...................................................................... 19
  Adding Clients to a Policy ............................................................. 20
  Specifying the SharePoint Portal Server Objects to Back Up ........ 21
  Testing NetBackup for SharePoint Portal Server Configuration Settings .......... 24

Chapter 4. Operating Instructions for SharePoint Portal Server ............ 25
  Backing Up a SharePoint Portal Server or a Folder of a Workspace ... 26
  Backing Up Documents in SharePoint Portal Workspace Folders .... 28
  Restoring a SharePoint Portal Server Installation ......................... 31
  Restoring a Folder of a SharePoint Portal Workspace .................. 33
  Restoring Versioned Documents to the Documents folder .......... 35
  Redirecting Objects to a Different Path ......................................... 39

Chapter 5. Disaster Recovery of a SharePoint Portal Server .............. 43
  Requirements for Disaster Recovery of a SharePoint Portal Server .. 43
  Recovering a SharePoint Portal Server and Its Data ....................... 44

Index ................................................................................................. 47
Preface

This guide explains how to configure and use NetBackup for Microsoft® SharePoint™ Portal Server to perform online backups and restores of Microsoft SharePoint Portal Server.

This guide is intended for system administrators responsible for configuring and maintaining systems using SharePoint Portal Server. This guide assumes that you have:

◆ A basic understanding of system administration.

◆ A working understanding of the NetBackup client and server software and are familiar with the information covered in the following NetBackup manuals:
  ◆ NetBackup Backup, Archive, and Restore Getting Started Guide
  ◆ NetBackup System Administrator’s Guide, Volume I
  ◆ NetBackup Troubleshooting Guide

◆ A thorough understanding of SharePoint Portal Server.
Getting Help

You can find answers to questions and get help from the NetBackup documentation and from the VERITAS technical support web site.

Finding NetBackup Documentation

A list of the entire NetBackup documentation set appears as an appendix in the NetBackup Release Notes. All NetBackup documents are included in PDF format on the NetBackup Documentation CD.

For definitions of NetBackup terms, consult the online glossary.

▼ To access the NetBackup online glossary

1. In the NetBackup Administration Console, click Help > Help Topics.

2. Click the Contents tab.

3. Click Glossary of NetBackup Terms.
Use the scroll function to navigate through the glossary.

Accessing the VERITAS Technical Support Web Site

The address for the VERITAS Technical Support Web site is http://support.veritas.com.

The VERITAS Support Web site lets you do any of the following:
◆ Obtain updated information about NetBackup, including system requirements, supported platforms, and supported peripherals
◆ Contact the VERITAS Technical Support staff and post questions to them
◆ Get the latest patches, upgrades, and utilities
◆ View the NetBackup Frequently Asked Questions (FAQ) page
◆ Search the knowledge base for answers to technical support questions
◆ Receive automatic notice of product updates
◆ Find out about NetBackup training
◆ Read current white papers related to NetBackup
From http://support.veritas.com, you can complete various tasks to obtain specific types of support for NetBackup:

1. Subscribe to the VERITAS Email notification service to be informed of software alerts, newly published documentation, Beta programs, and other services.
   a. From the main http://support.veritas.com page, select a product family and a product.
   b. Under Support Resources, click Email Notifications.
      Your customer profile ensures you receive the latest VERITAS technical information pertaining to your specific interests.

2. Locate the telephone support directory at http://support.veritas.com by clicking the Phone Support icon. A page appears that contains VERITAS support numbers from around the world.

   **Note** Telephone support for NetBackup is only available with a valid support contract. To contact VERITAS for technical support, dial the appropriate phone number listed on the Technical Support Guide included in the product box and have your product license information ready for quick navigation to the proper support group.

3. Contact technical support using e-mail.
   a. From the main http://support.veritas.com page, click the E-mail Support icon.
      A wizard guides you to do the following:
      ♦ Select a language of your preference
      ♦ Select a product and a platform
      ♦ Provide additional contact and product information, and your message
      ♦ Associate your message with an existing technical support case
   b. After providing the required information, click Send Message.
Contacting VERITAS Licensing

For license information, you can contact us as follows:

- Call 1-800-634-4747 and select option 3
- Fax questions to 1-650-527-0952
- In the Americas, send e-mail to americustomercare@veritas.com.
  In the Asia and Pacific areas, send email to apaccustomercare@veritas.com.
  In all other areas, send email to internationallicense@veritas.com.

Accessibility Features

NetBackup contains features that make the user interface easier to use by people who are visually impaired and by people who have limited dexterity. Accessibility features include:

- Support for assistive technologies such as screen readers and voice input (Windows servers only)
- Support for keyboard (mouseless) navigation using accelerator keys and mnemonic keys

For more information, see the NetBackup Installation Guide.

Comment on the Documentation

Let us know what you like and dislike about the documentation. Were you able to find the information you needed quickly? Was the information clearly presented? You can report errors and omissions or tell us what you would find useful in future versions of our manuals and online help.

Please include the following information with your comment:

- The title and product version of the manual on which you are commenting
- The topic (if relevant) on which you are commenting
- Your comment
- Your name

Email your comment to NBDocs@veritas.com.
Comment on the Documentation

Please only use this address to comment on product documentation. See “Getting Help” in this preface for information on how to contact Technical Support about our software.

We appreciate your feedback.
Comment on the Documentation
Introduction to NetBackup for SharePoint Portal Server

NetBackup for SharePoint Portal Server extends the capabilities of NetBackup to include online backups and restores of a Microsoft SharePoint Portal Server 2001 installation. You can also back up and restore the following folders in a workspace: Documents, Portal, Portal Contents, Dashboard. In addition, you can also back up the Shadow folder, which allows for the restoration of versioned documents to the Documents folder.

**Note** In this guide operations performed on a SharePoint Portal Server installation are referred as server operations. Operations performed on SharePoint Portal Server workspaces are referred to as workspace operations.

These capabilities are provided as add-ons to the NetBackup for Windows client software. Because this product is tightly integrated with the Backup, Archive, and Restore interface for Windows, this document only gives an overview of NetBackup functionality. Backup and restore operations for SharePoint Portal Server are identical to other NetBackup file operations, except where noted in this document.

For information on using NetBackup with SharePoint Portal Server 2003, see the guide for that NetBackup agent.

In this guide, Microsoft SharePoint Portal Server may be abbreviated either SharePoint Portal Server or SharePoint.
## Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Online Backup</td>
<td>SharePoint Portal Server objects can be backed up without taking the SharePoint Portal Server offline. This ensures the availability of SharePoint services and data during the SharePoint Portal Server backup.</td>
</tr>
<tr>
<td>SharePoint Portal Server Backup Methods</td>
<td>NetBackup supports full backups of SharePoint. Incremental backups are not supported.</td>
</tr>
</tbody>
</table>
| Tight NetBackup Integration | Tight integration with NetBackup means two things:  
1. An administrator already familiar with NetBackup procedures and software can easily configure and use NetBackup to perform SharePoint Portal Server backup and restore operations.  
2. Features and strengths of the NetBackup product suite are available to the SharePoint Portal Server backup user. These features include software data compression and encryption, scheduled and user-directed operations, multiple data stream backups, in-line tape copy, etc. Many of these features are described, in detail, in the NetBackup System Administrator’s Guide, Volume I. |
| Central Administration   | You can administer the backup and recovery policy of multiple SharePoint Portal Server installations from a central location. |
| Media Management         | SharePoint Portal Server backups are saved directly to a wide variety of storage devices supported by the NetBackup master server. |
| Automated Backups        | Administrators can set up schedules for automatic, unattended backups for local or remote clients across the network. These backups are managed entirely by the NetBackup server from a central location. The administrator can also manually back up clients. |
| Restore Operations       | Using a few simple operations, an administrator using the Backup, Archive, and Restore interface can browse SharePoint Portal Server backups and select the ones to be restored. |
| Redirected restore       | • In a redirected restore, you restore an object (document or folder) to a new location.                              |
Backup Operations

A backup can be made of the SharePoint Portal server or of the contents of any of the following workspace folders: Shadow, Documents, Portal, Portal Contents, or Dashboards. A server backup consists of the entire installation, whereas a workspace backup consists only of the documents or folders that you select.

SharePoint Portal Workspace Backup of the Documents Folder

A workspace backup of items from the Documents folder protects only the latest published version of the documents that it contains. It will protect the original version only if it has not yet been published. To protect earlier versions of documents, back up the Shadow folder or the Shadow contents that correspond to the document versions that you wish to protect.

Methods

NetBackup provides three methods to perform backups: automatic, manual, and user-directed. There are also three forms of automatic backup that are dependent upon the schedule type that is used for the backup. For general information on backup methods in NetBackup refer to the NetBackup System Administrator’s Guide, Volume I.
Backup Operations

Automatic Backups
The NetBackup administrator can schedule backups that occur automatically and unattended under the control of the NetBackup Server. For SharePoint Portal Server server backups, the entire contents of the server will be backed up regardless of the schedule type. However, the contents of a workspace automatic backup is dependent upon the type of schedule as follows:
- **Full schedule.** The entire contents in the Backup Selections list will be backed up.
- **Differential incremental.** Only the contents since the previous full or incremental will be included in the backup.
- **Cumulative incremental.** Only the contents since the previous full backup will be included in the backup.

Manual Backups
Manual backup may be used for special events. A manual backup includes the entire contents of the items selected for backup.

User-Directed Backups
User directed backups require a User Backup schedule to be defined on a SharePoint policy on the NetBackup Server. A user-directed backup includes the entire contents of the items selected for backup.

Contents of a SharePoint Server Backup
The following data is backed up during a backup operation.
- Microsoft Web Storage System files, which includes database files, log files, and backup patch files
- Microsoft Search Service (MSSearch) system resources, which includes the property store, subscriptions store, full-text index files, and propagated indexes
- SharePoint Portal Server configuration information, including Web Storage System configuration information, content source information, server properties, and access accounts
- The Applications folder, which contains a subfolder for each workspace on the server
- Shortcuts or content sources that reference the local file system
The following data is not backed up in a SharePoint Portal Server backup:

- Content source crawls (a content source is a URL that SharePoint Portal Server uses as a starting point to search or crawl for content in documents stored outside the workspace) scheduled using Microsoft Windows 2000 scheduled tasks
- Scheduled tasks for processing subscriptions
- Gatherer logs
- Lotus Notes configuration information

**Restore Operations**

Use the Backup, Archive, and Restore interface to initiate SharePoint Portal Server restore operations. This interface allows you to select the NetBackup Server from which the files will be restored as well as the client whose backups you wish to browse, and the destination client. Based upon these selections, you will be able to browse the backup history, select individual items and launch a restore.

**Server-Directed Restore**

A server restore recovers the entire contents of the installation to the condition in which it existed when the backup was made. The exception is that the following items are not restored:

- Content source crawls (a content source is a URL that SharePoint Portal Server uses as a starting point to search or crawl for content in documents stored outside the workspace) scheduled using Microsoft Windows 2000 Scheduled tasks
- Scheduled tasks for processing subscriptions
- Gatherer logs
- Lotus Notes configuration information

**Workspace Restore**

A workspace restore allows you to recreate individual documents or folders contained in the root folders `Documents`, `Portal`, `Portal Content`, or `Dashboards` folders of the workspace. The contents of a workspace cannot be restored to their original location if the documents and folders still exist in that location. Therefore, you must either delete the contents prior to the restore or redirect the contents to a new path. Documents must be restored to the same root folder from which they were backed up from. For instance, a document from `Documents` folder can only be restored to the `Documents` folder.
The Shadow directory contains a history of document revisions and therefore cannot be restored to its original location. To restore the Shadow directory you must redirect the restore to a folder with a name other than “Shadow.”

Redirecting a Restore to a Different Client
You can direct SharePoint Portal Server objects (including a server backup, or individual folders and documents) to a client other than the one from which they were backed up. This is possible if the NetBackup administrator sets up the configuration to allow it; and NetBackup for SharePoint Portal Server has been installed on the alternate client. The administrator using the NetBackup Administration Console on the master server or using the Remote Administration Console can direct restores to any NetBackup client (regardless of which client the files came from). Refer to the online help for the Backup, Archive, and Restore interface for information on redirecting restores to a different client.

Redirecting a Restore to a Different Path
A workspace restore can be redirected to a different workspace location from which it was backed up. You cannot redirect a server restore to a different path. In addition, individual contents of a workspace backup must be directed to the same root directory from which they were originally backed up.

Limitations on Backups and Restores
The following limitations exist when performing backups and restores of the SharePoint Portal Server and its workspaces.

Workspace Operations

- Only the Shadow, Documents, Portal, Portal Contents, and Dashboard folders of the workspace can be backed up and restored.
- The Shadow folder cannot be restored as the “Shadow” folder in the workspace directories. To restore this folder, redirect the restore to another folder outside of the workspace directories.
- When documents within a workspace are restored, the original date and time associated with the documents are not recreated.
- Security attributes are not restored.
Note If the Shadow folder of the workspace contains revisions to the documents in the Documents folder, it cannot be restored to its original location. In this case, choose the Restore everything to a different location (maintaining the existing structure) option in the Backup, Archive, Restore interface, and change the Destination.

For information on restoring to different location, see “Redirecting Objects to a Different Path” on page 39.

Redirecting a Server Restore to a Different Path

A server restore cannot be redirected to a different path because there is only one place on a client that the installation logically resides, i.e., Microsoft SharePoint Portal Server: \.

Server Operations

◆ The following data is not backed up in a SharePoint Server backup:
  
  ◆ Content source crawls (a content source is a URL that SharePoint Portal Server uses as a starting point to search, or crawl, for content in documents stored outside the workspace) scheduled using Microsoft Windows 2000 Scheduled Tasks
  
  ◆ Scheduled tasks for processing subscriptions
  
  ◆ Gatherer logs
  
  ◆ Lotus Notes configuration information
Limitations on Backups and Restores
Installing the SharePoint Agent

This chapter describes how to perform the following tasks:

- Verifying the prerequisites to enabling NetBackup for SharePoint Portal Server. The NetBackup for SharePoint Portal Server software is installed when you install NetBackup, so verify these prerequisites before enabling NetBackup for SharePoint Portal Server.
- Enabling functions specific to NetBackup for SharePoint Portal Server.
System Requirements

Software Requirements

The following software must be installed:

- NetBackup client software, Remote Administration Console for Windows, or NetBackup Server for Windows
- Client Components for Microsoft SharePoint Portal Server (these components are installed by default when the SharePoint Portal Server is installed), installed on the server
- Microsoft SharePoint Portal Server 2001
- Windows 2000

Account Requirements

The account used for backing up the SharePoint Portal Server (usually the NetBackup Client Service account) must have local administrator rights on the server where SharePoint Portal Server is installed.
Registering the License Key

NetBackup for SharePoint Portal Server is installed with the server and client software. To use this agent, register a valid license key for it on the master or media server.

▼ To register a license key

1. On the master or media server, open the NetBackup Administration Console.

2. Choose Help > License Keys.

3. Click the New button.

4. Type in the license key and click Add.
   For information on adding license keys, see the NetBackup System Administrator’s Guide, Volume I.
Registering the License Key
Configuration

This section provides an overview of how to configure NetBackup for SharePoint Portal Server to perform backup and restore operations.

◆ “Configuring the NetBackup Client Service Log On Account”
◆ “Configuring Backup Policies”
◆ “Testing NetBackup for SharePoint Portal Server Configuration Settings”
Configuring the NetBackup Client Service Log On Account

By default, the NetBackup Client service uses Local System as the account on which to log on. To perform individual backups or restores of workspaces or folders, the service account needs to be changed to a valid Windows domain account.

▼ To verify or modify the Log On account for the NetBackup Client service

1. Open the Windows Services application.

2. Double-click on the NetBackup Client Service entry.

3. Click on the Log On tab.

4. If Local System account is not selected as the Log on account, proceed with step 7.

5. Provide the name of the account you wish to use for backups and restores on this client.

**Note** To change this account, you must have administrator group privileges.

6. Stop and start the NetBackup Client Service.

7. Close the Services control panel application.
Configuring Backup Policies

A NetBackup policy defines the backup criteria for a specific group of one or more clients. These criteria include:

- storage unit and media to use
- policy attributes
- backup schedules
- clients to be backed up
- items to be backed up, including a list of databases and directives

To use NetBackup for SharePoint Portal Server, at least one MS-SharePoint policy with the appropriate schedules needs to be defined. A configuration can have a single policy that includes all clients or there can be many policies, some of which include only one client.

Most requirements for MS-SharePoint policies are the same as for file system backups. In addition to the attributes described here, there are other attributes for a policy to consider. Refer to the NetBackup System Administrator’s Guide, Volume I for detailed configuration instructions and information on all the attributes available.

Adding a New Policy

▼ To add a new policy

1. Log on to the server as administrator.
2. Start the NetBackup Administration Console.
3. In the left pane, right-click on Policies and choose New Policy.
4. In the All Policies pane, right-click on the Master Server, and click New.
   The Add a New Policy dialog displays.
5. In the Policy name field, type a unique name for the new policy.
6. Click OK.
   A dialog is displayed in which you can specify the general attributes for the policy.
7. From the Policy type box, select the MS-SharePoint policy type.
Configuring Backup Policies

Note The MS-SharePoint policy type will not appear in the drop-down list unless your server has a license key for NetBackup for SharePoint Portal Server.

8. Complete the entries on the Attributes tab. Refer to the section “Description of Attributes” on page 16 for details.

9. Add other policy information:
   - To add schedules, see “Adding New Schedules” on page 17.
   - To add clients, see “Adding Clients to a Policy” on page 20.
   - To add SharePoint objects to the Backup Selections list, see “Specifying the SharePoint Portal Server Objects to Back Up” on page 21.

10. Click OK. The new policy is created.

Description of Attributes

With a few exceptions, NetBackup manages a database backup like a file system backup. Policy attributes that are different for SharePoint backups are explained below.

Your other policy attributes will vary according to your specific backup strategy and system configuration. Consult the NetBackup System Administrator’s Guide, Volume I for detailed explanations of the policy attributes.

Description of Policy Attributes

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Policy type</td>
<td>Determines the type of clients that can be in the policy and in some cases the types of backups that can be performed on those clients. To use NetBackup for SharePoint Portal Server, you must have defined at least one MS-SharePoint policy.</td>
</tr>
<tr>
<td>Keyword phrase to associate with the backup</td>
<td>A textual description of a backup. Useful for browsing backups and restores.</td>
</tr>
<tr>
<td>Allow multiple data streams</td>
<td>Specifies that, depending on directives in the list of backup selections, NetBackup can divide automatic backups for each client into multiple jobs, with each job backing up only a part of the list of backup selections. The jobs are in separate data streams and can occur concurrently. The number of available storage units, multiplex settings, and the maximum jobs parameters determines the total number of streams and how many can run concurrently.</td>
</tr>
</tbody>
</table>
Adding New Schedules

Each policy has its own set of schedules. These schedules control initiation of automatic backups and also specify when user operations can be initiated.

The following procedures start on the Policy dialog. To see the Policy dialog, double-click the policy name in the Policies list of the NetBackup Administration Console.

▼ To add a schedule

1. On the Policy dialog, click the Schedules tab.

2. Click New.
   A dialog is displayed.

3. Specify a unique name for the schedule.

4. Select the Type of backup.
   For information on the types of backups available for this policy, see “Types of Backups” on page 18.

5. Specify the other properties for the schedule as explained in “Schedule Properties” on page 19.

6. Click OK.
   To add other schedules, repeat step 1 through step 6.
Types of Backups

Consider creating separate policies for incremental backups. A Backup Selections list is required for incremental backup operations. The list should specify the SharePoint Portal Workspace directive followed by the folder name.

Description of Types of Backups

<table>
<thead>
<tr>
<th>Type of Backup</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full backup</td>
<td>This schedule type is used to back up the SharePoint Portal Server database and associated transaction logs.</td>
</tr>
<tr>
<td>User backup</td>
<td>A user backup is not automatically scheduled and is initiated on the target client machine. You may want to consider creating a separate policy for User Backup schedule types. This will allow you to easily separate user-directed and scheduled backups when restoring files. If you decide to create separate policies for User Backup schedule types, the considerations are similar to those for automatic backups. A Files list is not needed because users select the files before starting the operation.</td>
</tr>
<tr>
<td>Differential-incremental backup</td>
<td>This schedule type is used to backup SharePoint Portal Server workspace folder's contents incrementally. Workspace folders that can be backed up are Shadow, Documents, Portal Content and Dashboards. A differential incremental backup will include the contents since the previous full or incremental backup.</td>
</tr>
<tr>
<td>Cumulative-incremental backup</td>
<td>This schedule type is used to backup SharePoint Portal Server workspace folder's contents cumulative incrementally. Workspace folders that can be backed up are Shadow, Documents, Portal Content and Dashboards. A cumulative incremental backup will include the contents since the previous full backup.</td>
</tr>
</tbody>
</table>
Schedule Properties

Some of the schedule properties have a different meaning for database backups than for a regular file system backup. These properties are explained in the following table.

Other schedule properties vary according to your specific backup strategy and system configuration. Consult the NetBackup System Administrator’s Guide, Volume I for detailed explanations of the schedule properties.

Description of Schedule Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of backup</td>
<td>Specifies the type of backup that this schedule will control. The selection list shows only the backup types that apply to the policy you are configuring. For more information see the following section, “Types of Backups.”</td>
</tr>
<tr>
<td>Frequency</td>
<td>This setting is used only for scheduled backups, and not for user-directed backups. Frequency specifies the period of time that will elapse until the next backup operation can begin on this schedule. For example, if the frequency is seven days and a successful backup occurs on Wednesday, the next full backup will not occur until the following Wednesday. Normally, incremental backups will have a shorter frequency than full backups.</td>
</tr>
<tr>
<td>Calendar</td>
<td>This setting is used only for scheduled backups, and not for user-directed backups. The Calendar option allows you to schedule backup operations based on specific dates, recurring week days, or recurring days of the month.</td>
</tr>
<tr>
<td>Retention</td>
<td>Specifies a retention period for keeping backup copies of files before deleting them.</td>
</tr>
</tbody>
</table>
Adding Clients to a Policy

The client list is the list of clients that will be backed up during an automatic backup. A SharePoint Portal Server client must be in at least one policy but can be in more than one. This procedure starts in the Policy dialog. To see the Policy dialog, double-click the policy name in the Policies list in the NetBackup Administration Console.

Requirements for clients

The following software must be installed on the client:

◆ SharePoint Portal Server
◆ NetBackup client or server
◆ NetBackup for SharePoint Portal Server

▼ To add clients to a policy

1. In the Policy dialog, click the Clients tab.

2. Click New.

3. Enter the name of the client you want to add.
   
   ◆ Type the name into the client list and click OK.
      
      If NetBackup cannot detect the hardware and operating system, a dialog displays so you can specify this information.
      
      OR

   ◆ Click the Browse for Computer button to choose the client from the network.

4. To add another client, repeat step 2 and step 3. If this is the last client, click OK to close the dialog.

5. If this is the last client, click OK.
Specifying the SharePoint Portal Server Objects to Back Up

The Selections list defines the SharePoint objects to be backed up. You can back up the entire SharePoint Portal Server, the Shadow, Documents, Portal, Portal Contents, or Dashboard folders, or individual documents in the workspace folders.

**Note** Directives from different directives sets should not be added to the same policy. For example, Microsoft SharePoint Portal Server:\ and Microsoft SharePoint Portal Workspaces:\ should not be added to the same policy.

**Note** SharePoint Portal Server database backups are required for disaster recovery. Workspace backups allow for document recovery, but are not adequate for disaster recovery.

Enabling Multiple Data Streams

When **Allow multiple data streams** is enabled (on the **Attributes** tab for a specific policy), automatic backups are divided into multiple jobs, with each job backing up only a part of the Files list. You control where each stream begins by inserting the NEW_STREAM directive at certain points in the Files list. For example, if you enable multiple datastreams and specify the following in the Files list, NetBackup will create a new stream for each workspace object.

```
NEW_STREAM
Microsoft SharePoint Portal Workspaces:\Workspace1\Documents
NEW_STREAM
Microsoft SharePoint Portal Workspaces:\Workspace2\Documents
```

▼ **To add a SharePoint Portal Server to the Selections list**

1. In the Policy dialog, click the **Backup Selections** tab.
2. Click **New**.
3. Click the **Directives** button.
4. From the **Directive set** list, select **MS_SharePoint__Portal_Server_2001**.
5. From the **Directive** list, select **Microsoft SharePoint Portal Server:**\.

![Select Directive dialog box](image)

6. Click **OK**.

   Microsoft SharePoint Portal Server: \ is added to the Selections list.

   ▼ **To add a folder of a workspace or items in a folder to the Selections list**

   1. In the Policy dialog, click the **Backup Selections** tab.

   2. Click **New**.

   3. Click the **Directives** button.

   4. From the **Directive set** list, select **MS_SharePoint_Portal_Server_2001**.

   5. From the **Directives** list, select **Microsoft SharePoint Portal Workspaces:**\.

   6. Click in the **Path Name or Directive** box and specify the folder to back up.

      See the Table “**Example entries in the Selections list**” for example entries.

      ◆ To back up an entire folder, append the name of that folder.

      ◆ For an individual folder, append the name of the folder.
◆ If adding items from multiple workspaces to the Selections list, multiple data streams must be enabled in order for backups to be successful. See “Enabling Multiple Data Streams” on page 21.

7. Click OK.

Example entries in the Selections list

<table>
<thead>
<tr>
<th>To back up</th>
<th>Example path</th>
</tr>
</thead>
<tbody>
<tr>
<td>A folder in a workspace</td>
<td>Microsoft SharePoint Portal Workspaces: \Workspace1\Shadow\</td>
</tr>
<tr>
<td></td>
<td>Microsoft SharePoint Portal Workspaces: \Workspace1\Documents\</td>
</tr>
<tr>
<td></td>
<td>Microsoft SharePoint Portal Workspaces: \Workspace1\Portal\</td>
</tr>
<tr>
<td></td>
<td>Microsoft SharePoint Portal Workspaces: \Workspace1\Portal Content\</td>
</tr>
<tr>
<td></td>
<td>Microsoft SharePoint Portal Workspaces: \Workspace1\Dashboards\</td>
</tr>
<tr>
<td>Items in multiple workspaces*</td>
<td>NEW_STREAM</td>
</tr>
<tr>
<td></td>
<td>Microsoft SharePoint Portal Workspaces: \Workspace1\Documents\NEW_STREAM</td>
</tr>
<tr>
<td></td>
<td>Microsoft SharePoint Portal Workspaces: \Workspace2\Portal\</td>
</tr>
</tbody>
</table>

* Allow multiple data streams must be enabled in order for this Selections list to be backed up successfully.
Testing NetBackup for SharePoint Portal Server Configuration Settings

After configuring the master server for NetBackup for SharePoint Portal Server, test the configuration settings. For a description of status codes, refer to the NetBackup Troubleshooting Guide for UNIX and Windows.

▼ To test the configuration settings

1. Log onto the server as administrator.
2. Start the NetBackup Administration Console.
3. In the left pane, click Policies.
   The policy list appears in the right pane.
4. Click on the policy you wish to test.
   The Manual Backup dialog is displayed.
   The Schedules pane contains the name of a schedule (or schedules) configured for the policy you are going to test. The Clients pane contains the name of the client(s) listed in the policy you are going to test.
6. Follow the instructions on the dialog.
7. Click Activity Monitor on the NetBackup Administration Console.
Operating Instructions for SharePoint Portal Server

This chapter describes how to perform user-directed backups and restores of SharePoint Portal Server objects in a Windows environment.
Backing Up a SharePoint Portal Server or a Folder of a Workspace

**Note** Only the Shadow, Documents, Portal, Portal Contents, and Dashboard folders can be selected for a backup.

▼ To back up a SharePoint Portal Server or a folder of a workspace

1. Log onto the server as Administrator.

2. Open the Backup, Archive, and Restore interface.

3. Choose **File > Select Files and Folders to Backup**.

   The Backup window is displayed.

4. In the All Folders pane, select the object to backup.
   - To back up the SharePoint Portal Server, select the Microsoft SharePoint Portal Server object.
   - To back up folders within a workspace, select the **Shadow, Documents, Portal, Portal Contents, and/or Dashboard** folder, or the individual folders within those folders, that you wish to back up.

Back up a folder in a workspace.

5. Choose **Actions > Start Backup of Marked Files**.
The Specify Backup Options dialog box is displayed.

6. Click **Start Backup**.

A dialog box is displayed informing you that the backup was successfully initiated. If you want to view the progress of the backup, click **Yes**. A View Status window is displayed, like the one shown below. If you do not want to view the progress of the backup, click **No**.
Backing Up Documents in SharePoint Portal Workspace Folders

**Note** Only the documents in the Shadow, Documents, Portal, Portal Contents, Dashboards folders can be selected for a backup.

▼ **To back up a SharePoint Portal Workspace document**

1. Log onto the server as Administrator.
2. Open the Backup, Archive, and Restore interface.
3. Choose File > Select Files and Folders to Backup.
   
   The Backup window is displayed.
4. In the All Folders pane, expand the folders in the Microsoft SharePoint Portal Workspace to backup.
   - To back up all the documents in the folder, select the Microsoft SharePoint Portal Server object.
To back up specific documents, select the individual documents within those folders that you wish to back up.

5. Choose Actions > Start Backup of Marked Files.
The Specify Backup Options dialog box is displayed.
6. Click **Start Backup**.

   A dialog box is displayed informing you that the backup was successfully initiated.
Restoring a SharePoint Portal Server Installation

This section describes how to restore a SharePoint Portal Server installation from a SharePoint Server backup image.

Caution  When you restore a SharePoint Portal Server, all SharePoint data on the target server is overwritten.

▶ To restore a SharePoint Portal Server

1. Log on as Administrator.

2. Open the Backup, Archive, and Restore interface.

3. Choose File > Select Files and Folders to Restore > from Normal Backup.
   The Restore window is displayed.

4. Choose File > Specify NetBackup Machines and Policy Type.
   The Specify NetBackup Machines dialog is displayed.

5. From the Source client for restores list, select the desired client.
   The source client is the SharePoint machine name whose backup images you would like to browse.

6. From the Policy type for restores list, select MS-SharePoint.

7. Click OK.
   NetBackup browses for SharePoint Portal Server backup images.
   The NetBackup History pane displays SharePoint Portal Server backup information. The top pane shows individual image information and the bottom pane gives folder and document information and also allows the user to select what objects are to be restored.

8. From the NetBackup History pane, select the image containing the objects you wish to restore.
9. In the All Folders pane, select the Microsoft SharePoint Portal Server object.

10. Choose Actions > Start Restore of Marked Files. The Restore Marked Files dialog box is displayed.

11. Click Start Restore.
Restoring a Folder of a SharePoint Portal Workspace

NetBackup can restore the Documents, Portal, Portal Contents, or Dashboard folders, or individual folders in those directories, from an SharePoint workspace backup. If you wish to restore the Shadow folder, follow the instructions in the section “Restoring Versioned Documents to the Documents folder” on page 35.

**Note** If you wish to perform a workspace restore and the original folder still exists at the same location, then you must redirect the restore to a different location.

▼ **To restore a folder or subfolders within the folders**

1. Log on as Administrator.
2. Open the Backup, Archive, and Restore interface.
3. Choose File > Select Files and Folders to Restore > from Normal Backup.
   The Restore window is displayed.
   The top pane of the NetBackup Restore window shows individual backup image information. The bottom pane shows file and folder information for the selected image from the top pane and allows for selection of SharePoint Portal Server objects to be restored.
4. Choose File > Specify NetBackup Machines and Policy Type.
   The Specify NetBackup Machines dialog box is displayed.
5. From the Source client for restores list, select the desired client.
   The source client is the SharePoint machine name whose backup images you would like to browse.
6. From the Policy type for restores list, select MS-SharePoint.
7. Click OK.
   NetBackup browses for SharePoint Portal Server backup images.
8. Select an image from the NetBackup History pane.
9. In the All Folders pane, expand the workspace containing the folder to restore.
10. Select a folder to restore.

11. Choose Actions > Start Restore of Marked Files.
12. Click Start Restore.

For information on restoring to different locations, see “Redirecting Objects to a Different Path.”

Restoring Versioned Documents to the Documents folder

The backed up Documents folder contains only the latest published version or original version (if not published) of the files. To restore these files, perform a normal document level restore.

Other revisions of the files are located in the Shadow folder, with the same folder structure as the original copy. The revisions of a file in the Shadow folder can be identified by the following name format: original_name(x.y).ext where original_name is the name of the file, ext is the file extension, x is the published version of the file, and y is the draft version of the file.
To restore other revisions of files

1. Open a Restore window.

2. From the NetBackup History pane, select an image that contains the files you wish to restore.

3. In the All Folders pane, expand the workspace containing the folder to restore.

4. Expand the Shadow folder for the workspace.

5. Select the revisions to restore.
   a. Choose Actions > Start Restore of Marked Files.
   b. Select Restore everything to a different location.
   c. Click in the Destination box and remove the Shadow folder from the pathname.

   ![Restore Marked Files dialog box](image)

   d. Click Start Restore.
To rebuild the restored revisions into a consolidated SharePoint versioning

1. Perform a restore of the Documents folder.

2. Perform a restore of all revisions (as noted in the previous procedure).
   After restoring all of the revisions, the view of the folder from Windows Explorer
   should show the base document (Project 1 manual.doc in this example) and all
   of the revisions (Project 1 manual(0.1).doc, Project 1 manual(0.2).doc,
   etc.).

   a. Right-click on the document.
   b. Select Check In from the menu.
   c. Add the appropriate Version comments and Document profile information.
   d. Click OK.

   After the initial check-in from the Windows Explorer interface, all subsequent
   check-ins can be performed from either the Windows Explorer interface or the
4. From the SharePoint Portal Server Document Library web page, right-click on each revision of the file (i.e., the restored Shadow folder documents), and click Save Target As (or Save or Save As) and save the file to a temporary location.

5. Below the listing for the first revision of the document restored in step 1, click Show Actions.

6. Click Check In.

7. Browse to the temporary location for the revisions restored in step 4.

8. Select the oldest revision that needs to be checked in.

9. Check in this revision of the file. Update document profile as necessary.

10. Publish the file as necessary to maintain appropriate versioning.

11. Check out the file (it is not necessary to save the file).
12. Repeat steps step 6 through step 11 for all remaining revisions.

13. Delete the restored revision files from the Documents folder (leaving the base document).

Redirecting Objects to a Different Path

If documents are restored to their original locations, they will lose certain attributes. Alternatively, you can direct a restore to a different path.

▼ To restore all objects to a different location

1. Open a Restore window.

2. In the left pane, expand the Workspace containing the objects you wish to restore.

3. Select the folder, or subfolder, to restore.

4. Choose Actions > Start Restore of Marked Files.

5. In the Restore Marked Files dialog, select Restore everything to a different location.

Note The Browse button does not browse SharePoint objects and should not be used. It is only useful for browsing file systems.

6. In the Destination box, change the destination to restore to.
   - To direct the restore to a different workspace, change the workspace portion of the Destination field to another existing workspace.
   - To direct the restore to a different folder within the same workspace, indicate the the name of the subfolder in the destination.
Redirecting Objects to a Different Path

**Note** When restoring from NetBackup images, you must indicate an explicit path (or full path) for the **Source** and **Destination** for this option to be successful.

7. **Click Start Restore.**

   ▼ **To restore individual objects to different locations**

1. Open a Restore window.

2. In the left pane, expand the workspace containing the objects you wish to restore.

3. Select the folders, or subfolders, to restore.

4. Choose **Actions > Start Restore of Marked Files.**

5. In the Restore Marked Files dialog window, select the **Restore individual folders and files to different locations.**

   Each row under **Restore individual folders and files to different locations** is associated with a selected folder to restore.

6. Double-click on a row to modify the destination.

   The Enter New Destination dialog is displayed.
7. In the **New** box, change the destination to restore to.
   The destination can be any valid existing SharePoint folder path.

8. Click **OK**.

9. Click **Start Restore**.
Redirecting Objects to a Different Path
Disaster Recovery of a SharePoint Portal Server


If you purchased the Intelligent Disaster Recovery (IDR) option, see the “Intelligent Disaster Recovery” Appendix in the NetBackup System Administrator’s Guide for Windows, Volume I, for directions on using IDR to recover a Windows 2000 Server. If you do not have IDR, see the “Disaster Recovery” chapter in the NetBackup Troubleshooting Guide.

After recovery of the Windows 2000 server is complete (after the last reboot), the SharePoint Portal Server software is installed but is not functional. SharePoint Portal Server must be removed and then reinstalled before the SharePoint data can be restored.

Requirements for Disaster Recovery of a SharePoint Portal Server

- A copy of NetBackup for Windows with the SharePoint Portal Server Agent license added on the master server
- The latest backup of the SharePoint Portal Server you want to recover
- The SharePoint Portal Server CD
- Any service packs that have been applied to the original installation
Recovering a SharePoint Portal Server and Its Data

Use the following procedures to complete the recovery of a SharePoint Portal Server and the associated SharePoint data.

▼ To recover a SharePoint Portal Server

1. Log on as Administrator.

2. Insert the SharePoint Portal Server CD, and then when the browser screen appears, click Exit.

3. Choose Start > Settings > Control Panel.

4. Double-click Add/Remove Programs.

5. In the Add/Remove Programs dialog, select SharePoint Portal Server, and then click Change/Remove.

6. Click Uninstall SharePoint Portal Server services from the computer, and then click Next.

7. Click Yes to acknowledge the warning about deleting SharePoint Portal Server data, files, and folders.

8. When the uninstall is complete, click Finish, and then restart the server.


10. Install the SharePoint Portal Server software to the desired location with the appropriate options, and then click Finish.

11. When the New WorkSpace Wizard starts, click Cancel.

12. Apply any service packs that were applied to the original installation.

▼ To restore SharePoint data

1. Log on as Administrator.

2. Open the Backup, Archive, and Restore interface.

3. Choose File > Select Files and Folders to Restore > from Normal Backup. The Restore window is displayed.
4. Choose File > Specify NetBackup Machines and Policy Type.
   The Specify NetBackup Machines dialog box is displayed.

5. From the Source client for restores list, select the desired client.
   The source client is the SharePoint machine name whose backup images you would like to browse.

6. From the Policy type for restores list, select MS-SharePoint.

7. From the Destination client for restores list, select the desired client.
   The destination client is the SharePoint machine name to which you want to redirect the restore.

8. Click OK.
   NetBackup browses for SharePoint Portal Server backup images.

9. From the NetBackup History pane, select the image containing the objects you wish to restore.

10. In the All Folders pane, expand the Microsoft SharePoint Portal Server object.

11. Select the folders you wish to restore.

12. Choose Actions > Start Restore of Marked Files.
    The Restore Marked Files dialog box is displayed.

13. Click Start Restore.

14. After the restore completes, VERITAS recommends that you perform a full backup of the restored databases.
Recovering a SharePoint Portal Server and Its Data
Index

A
accessibility features viii
Activity Monitor 24

B
backup operations, described 3
Backup Selections list, adding SharePoint objects 21, 22
backup types
full 18
user 18
backups
automatic 4
data not backed up 7
user-directed 4

C
Clients list 20
configuring NetBackup, for workspace operations 14

D
directives
mixing directive sets 21

F
full backup 18

I
installation 11

L
license keys, registering 11
limitations of backups and restores 6

M
manual backups 4
multiple data streams 21

N
NetBackup Client service account, verifying/modifying 14

P
policy configuration
attributes 16
clients 20
overview 15
schedules 17
specifying objects to back up 21

R
restores
server-directed 5
retention period 19

S
schedules
adding 17
frequency 19
properties 19
retention 19

U
user backups 18

W
workspace operations, configuring
NetBackup for 14