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Turning on Interactive Viewer
Before you begin applying conditions and formatting, ensure you turn on the Interactive Viewer:

1. First, ensure you select New Version from the Report Version dropdown, add in your report
parameters, then click Fetch Report.

Transaction Details Summary Help X

e
Veraon,  Mew Version
R Evrr—|
View By @ [Summary ~

From (MMIDDAYVY
Date. @ | 01/01/2022 eg. 4/11/2004)
(MMIDDAOVY

eg. 4/11/2004)

To Date: @ [08/31/2023
ot o9 223010223510
051 or 223010,
Centre: @ | 230642230087 223460-223510,
223840

o J 100 @200 O30 Oaoo O so
COeon O700 Ceoo Csoo O ooo

At @ ] eg. 301000-309000

Activity: @

Fund:

Time: @

Location: @

Source
] I

2. Optional: Once your report opens, you may wish to select the Raw data view option. This may
not be available for all reports.

Fund Code: Run Date Time:
\Cost Centre: 230087 Demo 230087 TRANSACTION DETAIL Manager: . Tay

IStart Date: 03012009 End Date: 12312099 For the period: 01 9 thrn  083L Location: Keele Campus
|Cost Centre Statuz: ACTIVE HST Rebate Rate: % Department: 47350 Dept 47350

Outstanding PO Commitments can be reviewed in the Ouistanding PO Commitments Report
<= Raw data view =» 2 == Click here for Detailed Sm@rtBuy | Concur Expenzes ==

JEPT—y ———
Transsction Description 5 PO Reference Vendor / Reference

Revenue Accounts

033000 ICR Sal-Wages
0 ICR Sal-Wazges. BU BU00833802 BU30M BU3024 61.488.00 -
04282023 Tf KimK upgrade project ULC 0000847381 771130 - (287.02)
| Total- 133000 - ICK Sal.-Wass: SLAES0 fenpa |

3. Enable Interactivity by opening the Main Menu (hamburger icon in the top-left of your screen).

4. Click Enable Interactivity.

TRANSACTION DETAILS REPORT
¥ Parameters T —— Jrey—— Transaction Line Description  Source
i Table of Contents

n 2002 Expanze 436600 Equip Computer-Under §: 4112022 1x laptop SRE66160 e
20 Linkto this page 2022 Expense 486600 Equip Computer Under $20,000  04/112022  Lx dock SRE66160 e
2 2022 Expense 240100 BenFt Support Staff Yuss 02242022 T# MileyC payment uc
20 Exportcontent Ctrl + Shift+ E 2022 Expense 140100 Sal Ft Support Yusa 02242022 T MileyC payment uLe
n Export data 2022 Expense 455000 Computer Softwara Licansa Faa (4282022 TNCE73314 SEP e
2 2022 Expense 453000 Computer Softwars Licsnsa Fas (4282021 THCET3318 Res Grad e
a Print Corl=p 2022 Expense 455000 Computer SoftwareLicenss Fas 047282027 License Fee me
2 2022 Expense 455000 Computer Software-LicenssFes (4282022 License Fee ue
20 Keyboard Shorteuts Ctrl+/ 2022 Expense 455000 Computer Software License Fee (4282022 SMS =l uLC
20 Help Ctrl+F1 2022 Expense 435000 Computer Software-Licensa Fea 04282012 DNC29644 Sciance =2 uc
20, S S S 2022 Expensa 455000 Computer Softwars Licansa Fas INC613201 HR =7 uc
200 230087 Demo 230087 Swift Taylor 2023 Expanse 140000 Bal Ft Support Sta-CPM Sal Fit Support Sa-CPM BU
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Formatting Options
In this section, we will cover all the different formatting options. Before you begin, ensure you've
followed the steps to turn on the interactive viewer:

1. Select a column.
2. Click the ellipsis icon (...) from the interactive viewer menu.
3. Open the Format dropdown.
4. Select your Format option.
i} TRANSACTION DETAILS REPORT
eader
18 Group e Type  Account iption . ‘Transaction Line Deseription  S¢
I Column
Y Agsregation ‘Equip Computer Under $20,000 & 1x dock SRE66160 e
Maximize
t Sort ’ Conputa Sofvare LicemsaFaa 0472 uc
Alignment Conputer Sofiware License Fez - 0 ULC
Aa Format e
0! e
Copy Style b oo apport StECPML 5
E.X port content Conditional Formatting Q 2 5U
it Tplor 35 Ed| = FormatData == BaFiSupenSuECM 5U
. - e
Swift Taylor 0 Ex opyForma lewspapers. Books-Periodicals-Newspapers ~ BU
Font

Selecting the Font option will open the Font Window, allowing you to edit a column or the entire table:

1. Font: allows you to choose a font from 8. Apply: allows you to apply your changes
a dropdown of dozens of options. to your column or table.

2. Size: allows you to customize the font
size of your column or table. ___

3. B/1/U: the bold, italic, and underline fort
options work much as they do in Word
or Excel, allowing you to enhance the
text of your column or table.

4. Colour: allows you to change the font
colour

5. Background Colour: allows you to
change the cell colour. Remember to —
keep accessibility in mind when \negame
choosing colours.

6. Apply to Table/Column: Apply to
Column allows you to apply your
desired font changes to the selected

. () apply totable
column. Apply to table applies the o P

[ Fantasy v ]

Size:
ER— 1 €

Color

[reB1s351102) |

VA

e

# | 0oocoo

Pick Calor

| custom Colors

Pick Color

changes to the entire table.
7. Preview: generates a preview of how
your changes will appear.

AaBhCcYylz

= O
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Copy Style

Copy Style allows you to copy the format changes of one column and apply them to another, which is
helpful if you want several columns to stand out without formatting the entire table or repeating
manual steps.

1.

4.

Select a previously-formatted column; if the selected column has no custom formatting, you
won't have anything to copy.

Select Copy Style from the Format dropdown.

Select the column(s) you'd like to apply your copied format to. You can hold Shift or CTRL to
select multiple columns at one time.

Click Apply.

TRANSACTION DETAILS REPORT

Fiscal Year -
Account Type

Account

200 230087 Swift Taylor 2022 Expense 486600 04112022 1 laptop SRE66160
? " Demo 230087 " “  Equip Computer-Under $20,000 °

Account Description 200 230087 Demo 230087 SwifTavlor 202 Expanse 456600 ‘-. IEII-IIIOI-I*I SM.n Q4112022 1 dock SREESIS0
Date 200 20642 lllllll 230“2 St Tayler 202 Expense 2400 .'n “ s.lll ort SI 3 'f' Té MileyC payment
Transaction Line Description 200 20642 lllllll 230“2 St Tayler 202 Expense 140100 SI| HSIIIII.I'I ' Té MierC payment
Transaction Source - 200 230087 ||'IIII zaom St Tayler 202 Expense 455000 e.'_“' sm'._un“ '.. 04282027 INCETI3L4 SEF

INCST3318 Res Grad

Demo 230087 = Computer Software-License Fee
® = Deme93008] “**~ *° = “ (CpmpuletSofware-licensaFee "
=" Demeo 230087 ¢ ¢ 7 “""  Gomputer Software-license Fes -
50 SMS=xl

200 230087 nmn zanm Swif Tavlor 2022 Expense 455000 e.m' sm'._un“ '.' o4
200 230087 nmn zaum Swif Tavlor 2022 Eapense 455000 e.'_l.' sm',_un“ '.. 04282022 INCE296+4 Sciencesd

Licensa Fee

License Fee

Conditional Formatting
eReports' Conditional Formatting works much the same way it does in MS Excel.

1.
2.
3.

O N U, ke

Select any column to open the Interactive Viewer menu.

Select Conditional Formatting from the Format dropdown.

Click Format to open the Font window. This is how you will add the formatting that will be
applied to the values that meet your chosen condition.

Conditional Formatting Font
cected Coumn Font
Fiscal Year
Fantas) v
— Ly \
=
e | —
e v [8]

S ="
coor
ol (Fcarenr VI (Greserman V\]o o

[ReBo285.0)

Valoe (i EE
o oz | cransevane Backand ot
RGB(255.0,0)

Lo | I D)
Column Name: allows you to select the column you wish to apply the conditional formatting to.
Condition: enables you to select the condition to apply to your column.

Value: allows you to type in the value or criteria your condition will be applied to.

Add Rule: You can use the Add Rule button to add another conditional formatting rule.

Apply: will apply the conditional formatting to your column.
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Format Data

Format Data allows you to format numerical data into recognized formats like dates, percentages, etc.
To format a column's data:

1.

Select a data column; the feature won't 8.

work if you select a text column like 9. Negative numbers: allows you to

Cost Manager. choose whether negative numbers will
Select Format Data. be presented in parentheses or prefixed
Format Number as: allows you to select with a negative "-" symbol.

the number format you'd like to apply 10. Apply: applies your formatting to the

to your data column. For this example, selected column.

we are choosing Currency.

Symbol: is unique to Currency; it asks
you to choose which currency symbol Formt Number o2

you wish to apply to your column. (e a
NOTE: This won't automatically

Number column format

Unformatted

\

General Number

Currency

calculate the exchange rate of the Fired
Percent

selected currency. o

Symbol position: also unique to Custom

Symbol

[ cas v|

currency, it allows you to select if you'd
prefer the currency symbol to appear
before or after the value.

Decimal Places: allows you to select
how many decimal places your value
will show.

Use 1000s Separator: allows you to

Symbol Position

| Before ~ |

Decimal Places:

Lo ~]

Use 1000s Separator

Negative Numbers:

[123258 v

AAA A

choose whether your values will be 123456

(1234.56)

comma-separated by 1000s. e.g., [ﬂl
1300.34 vs 1,300.34.

Copy Format
This feature allows you to copy a data format from one column to another or even multiple columns.
Complete the Format Data section above for this example.

1.

Select a data column with a data format already applied to it; the feature won't work if you
select a text column like Cost Manager.

Select Copy Data from the Format dropdown.

Select the column(s) you'd like to apply the copied data to.

Click Apply.

Copy Format

Fiscal Year

Transaction Amount
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Column Options

This section will cover all the different options for editing columns. Before you begin, ensure you've
followed the steps above to turn on the interactive viewer:

Once interactivity is turned on:

1. Select a column.

2. Click the ellipsis icon (...) from the interactive viewer menu.

3. Open the Format dropdown.

4. Choose a formatting option.

TRANSACTION DETAILS REPORT
Fund Code | Cost Centre Name | Coxt Centy o Column Hide Column Transaction Line Description
Show Column
oo Damo 230087 Swift Taylor X Aggregation & Delete Column 72 lxlaptop SRE66160 uc
H] Demo 230087 Swifh, Taylor Y Filter » New Computed Column SRS6§160 e
oo Demgc 230842 Swift Taylor 22 C payment ULC
200 Deme 230642 Swift Taylor P 22 Tt MileyC payment TLe
N Maximize
boo Demo 230087 Swift Taylar Move To Left 27 TNC673314 SEP e
oo Demo 230087 Swift Taylor Move To Right 27 TNC673318 Res Grad e
13
200 Deme 230087 Swift Taylor ‘ sart Reorder Columns 22 License Fes ULC
boo Demo 230087 Swift Taylor Alignment 4 22 Licanse Fee ue
oo Dermo 230087 Swit Taylor Aa Format » Do Mot Repeat Values 2 SMSxl ULC
200 Demo 230087 Swaft, Taylor T 22 INC629644 Science 2 ULC
oo Demo 230087 Swit Tavlor Export content Computer Software Licensa Fee (4282022 DNCS13201 HRE x7 ULC
oo Deme 230087 Swifh Tavlor cves papmme amee 2l Ft Support St CPAL 22 Sal Ft Support StaE-CPM BU
lEDU Demo 230087 Swat Taylor 2023 E = 138100 Sal Overtime Yusa 0372 22 Sal Overtime Yusa BU

Hide Columns

Allows you to hide columns in a report. This can help reduce the complexity of a report by removing

extraneous data.

1. Inthis example, we'll select the Fund Code and Cost Center columns. You can select multiple

columns by holding CTRL and clicking those columns.

2. Then select the Hide Column option to hide all the selected columns.

Unhide Columns (Show Columns)
The Show Column feature will show/unhide your report's hidden columns.

To unhide columns:

1. Select any column and choose the Show Column option under Column.
2. Onthe Show Columns window, select the columns you want to unhide. You can select multiple
by holding Shift or CTRL while you click.

3. Click Apply

Pick hidden column:

Fund Code
o Cost Centre Manager

O
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Delete Column

Deleting columns allows you to delete a column from your report. Note this will only delete it on your
opened copy of the report—it will not delete the data from the eReports database.

To delete column(s):

1. Select the column(s) you want to delete. You can select multiple by holding CTRL while you click.
2. Choose the Delete column option from the Column dropdown in the interactive viewer menu.
3. Click Continue.

Your column(s) are now deleted. You can immediately click Undo from the main menu to re-add the
columns.

New Computed Column

This feature allows you to add new columns to your report. This powerful feature enables custom
functions, much like Excel. In our example, we will forecast an inflation rate of 1.04%.

To add a custom Computed Column: New Computed Column

Column Label

1. Select the column adjacent to where
you want to add the computed column.

‘ Inflation |

Select Category:

2. Select the New Computed Column Wiath 7]
H Comparison
option under Column. ° e
3. Inthe Column Label field, type the Text

Math

name of your computed column. We
are using "Inflation" in this example.

Date & Time

173

elect Function

4. Select your desired category from the PR
. . ADD
Select Category list; we are selecting .
Math. CEILING
. . . DIFFERENCE
5 In the. Select Function list, cI!ck a ' o s
function. To type an expression, click PRODUGT
the Advanced category. RANK
a. Information about your chosen EAOEZD
function will appear below. ROUNDDOWN

ROUNDUP

6. Inthe Enter Expression field, type your
custom expression:
a. Reference any column using a
square bracket "[" followed by
the column's name. L O a0

[TRANSACTION_SOURCE] - Transaction Source
[[TRANSACTION_AMOUNT] - Transation Amount

b. Select a column; we are TRANSACTION 0] - ournal | Py Joucher 0
choosing Transaction Amount.

c. Next, add the multiplication
symbol "*" followed by the valoate

value 1.04. E=n -~ £7]

7. Click Apply.

SQRT

o This option enables you to customize a function expression.

[Erter Expression:

[TRANSACTION_AMOUNT] * 1.04
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Move To Left/Right
This feature allows you to move a column to the left or the right of its current position.

To move a column:

1. Select the column you want to move.
2. Choose the Move to Left or Right to move the selected column in your desired direction.

For more complex moves involving multiple columns, use the Reorder Columns option below.

Reorder Columns
This feature allows you to rearrange multiple columns with only a few clicks.

To reorder columns:

Select any column.

Choose the Reorder column option from the Column dropdown in the interactive viewer menu.
Select the column you'd like to move from the Available Columns list.

Use the up and down arrow keys to reorder the column as desired.

Repeat steps 2 & 3 as necessary.

Click Apply.

Reorder Columns

Available Columns;

Fund Code
~

o Cost Centre o
v

Cost Centre Name

ok wnNPE

Do Not Repeat Values

The Do not Repeat Values feature will remove any repeating values in a column, replacing them with
blank cells instead.

1. Select any column with repeating values.

2. Choose the Do Not Repeat Values option from the Column dropdown in the interactive viewer
menu.
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Video Tutorial

Check out our video tutorial for a more detailed look into modifying columns using the new eReports:

¥y
Editing Columns & s wse omm o

Applying Formatting -“\

with the New eReports ..I.

Use the link if you have trouble accessing the video: https://www.youtube.com/watch?v=gq1MkYrTS E.
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https://www.youtube.com/watch?v=gq1MkYrTS_E
https://www.youtube.com/embed/gq1MkYrTS_E?feature=oembed

	Turning on Interactive Viewer
	Formatting Options
	Font
	Copy Style
	Conditional Formatting
	Format Data
	Copy Format

	Column Options
	Hide Columns
	Unhide Columns (Show Columns)
	Delete Column
	New Computed Column
	Move To Left/Right
	Reorder Columns
	Do Not Repeat Values

	Video Tutorial

